Description
There is an integer array A1, A2 …AN. Each round you may choose two adjacent integers. If their sum is an odd number, the two adjacent integers can be deleted.
Can you work out the minimum length of the final array after elaborate deletions?
Input and Output
输入
The first line contains one integer N, indicating the length of the initial array.
The second line contains N integers, indicating A1, A2 …AN.
For 30% of the data:1 ≤ N ≤ 10
For 60% of the data:1 ≤ N ≤ 1000
For 100% of the data:1 ≤ N ≤ 1000000, 0 ≤ Ai ≤ 1000000000
输出
One line with an integer indicating the minimum length of the final array.
样例提示
(1,2) (3,4) (4,5) are deleted.
样例输入
7
1 1 2 3 4 4 5
样例输出
1
Codes
The ideas: After multiple deletion, in the end there are only all evens or odds. So just calculate the number differences between the evens and the odds.
#include <iostream>
using namespace std;
int main() {
int count = 0;
int n, a;
cin >> n;
while (n--) {
cin >> a;
if (a%2 ==0)
count++;
else
count--;
}
cout << (count>0?count:-count) << endl;
return 0;
}